Symptôme
Si vous tentez de réinitialiser (effacer) un disque virtuel à l’aide du pilote virtuel de la communauté, vous risquez de réinitialiser le mauvais disque. Vous recevrez le message d’erreur « Plusieurs disques trouvés avec le même ID. Mettez à jour votre pilote de stockage, puis réessayez. »
Cause
Lorsque vous utilisez le pilote virtuel communauté, il existe des disques virtuels qui peuvent avoir le même UniqueId. Cela peut créer des problèmes lorsque vous lancez une opération de réinitialisation. L’opération de réinitialisation réinitialise le premier disque trouvé. Toutefois, il se peut qu’il ne s’agit pas du disque que vous souhaitez réinitialiser. Pour cette raison, ce disque perd des données.
Résolution/solution de contournement
Vous pouvez utiliser les commandes PowerShell ci-dessous pour récupérer et réinitialiser (effacer) un disque.
-
Pour récupérer des détails sur les disques, tapez Get-PhysicalDisk | Select-Object -Property FriendlyName, DeviceID, UniqueId
-
Vérifiez les détails du disque que vous souhaitez réinitialiser. Utilisez deviceId du disque comme numéro dans la commande Clear-Disk [-Number] <UInt32[]>
Plus d’informations
Pour plus d’informations, consultez Get-PhysicalDisk et Clear-Disk.